Raspberry Pi: Time sync

When I tried to do a regular update on a Raspberry Pi 1 with sudo apt-get update, I got this error message:

E: Release file for http://raspbian.raspberrypi.org/raspbian/dists/buster/InRelease is not valid yet (invalid for another 1d 14h 44min 54s). Updates for this repository will not be applied.

Checking the date I saw that the Pi was not in sync with time. Adjusting the date is easy:

$ sudo timedatectl set-time "2019-11-09 21:25:00"

and now it worked again. Thanks Patric Fromaget / raspberrytips.com for the solution I found with a quick web search.

Leave a Reply